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1. Introduction to Kernel for VHD 

1.1 Using this Manual 

Welcome to the user manual of Kernel for VHD which is an output-driven tool that repairs corrupted or 

damaged Virtual Hard Disk files and recovers data from them. This user manual helps in using the tool 

efficiently. It is recommended that novice, as well as experienced users, should carefully go through this user 

manual before using the software. A user who is aware of the software can even use the table of contents for 

finding the particular portion of the manual. The Table of Contents (TOC) enlists all the sections described in 

this manual from where one can navigate through different sections of this user manual. The user manual 

consists of step-by-step guidelines for using Kernel for VHD.  

 

1.2 Introduction to Kernel for VHD 

Kernel for VHD is an advanced, effective, and powerful tool that repairs corrupted, damaged or inaccessible 

VHD and VHDX files accurately and flawlessly. The utility supports VHD and VHDX files created using Windows 

10, Windows 8.1, Windows 8, Windows 7, Windows Server 2008 R2 and Hyper-V Server. The software 

comprises three powerful recovery modes for recovering data that got lost due to various reasons. The 

software preserves the data integrity, formatting and properties while recovering.  

The VHD/VHDX files may get corrupted due to various reasons such as virus attacks, RAID failure, accidental 

damage due to fire or water, hard disk crash, damaged storage media, unintentional deletion of data stored 

in the hard disk, and so on. Kernel for VHD uses powerful algorithms for restoring the lost or deleted data and 

is fast, simple and easy-to-use software. 
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1.3 Salient Features 

Key features of Kernel for VHD are: 

• Recovers data from lost, deleted, inaccessible, corrupted or damaged VHD and VHDX files. 

• Recovers all types of data such as image files, video files, audio files, database files, documents, 

media files, archives, etc. 

• Resolves all types of corruption issues in VHD and VHDX files. 

• Restores permanently deleted files in a single attempt. 

• Recovers large-size VHD and VHDX files without any restrictions. 

• Provides three powerful recovery modes -Quick Scan, Extensive Scan, and File Trace for recovering 

data. 

• Provides options to quickly search the VHD partitions using VHD/VHDX file. 

• Users can show or hide the progress of the data retrieving process. 

• Configure settings to include/exclude deleted files, skip duplicates, etc. 

• Preview all the recovered files of the virtual hard disk. 

• Supports recovery of data from VHD/VHDX files created using Windows Server 2008, Windows Server 

2008 R2, Windows Server 2012, Windows Server 2012 R2, Windows Server 2016, Windows Server 

2019, Hyper-V Server, Windows Vista, Windows 7, Windows 8, Windows 8.1, and Windows 10. 

 

2. Getting Started 
Now that you have understood the features and potential of Kernel for VHD, you are ready to get the hand- 

on experience of the software. To start repairing VHD/VHDX files, you will first need to download and install 

the tool. It is strongly recommended that before installing Kernel for VHD, you should go through the 

installation pre-requisites for the software to ensure that your computer is appropriately configured to run 

the software. 

2.1 Installation Pre-requisites 

The various pre-requisites for installing and running Kernel for VHD tool can be broadly classified into two 

major categories – Hardware requirements and Software requirements. 

 
 

2.1.1 Hardware Requirements 

The hardware requirements for installing the software are as follows: 

• Pentium Class Processor 

• 64 MB RAM (128 MB recommended) 

• Disk Space Requirement - 50 MB of Free Space 
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 The free trial version of Kernel for VHD accurately recovers lost and inaccessible files 
from corrupt VHD partitions, provides preview and saves files up to 250 MB. To save 
unlimited recovered files, you have to purchase the full version of the software.  

• Enough disk space to save results 

 
2.1.2 Software Compatibility 

The software requirements for installing the tool are as follows: 

Supported MS Windows Operating System:  

• Windows 10 

• Windows 8.1 

• Windows 8 

• Windows 7 

• Windows Vista 

• Windows XP 

• Windows 2000 

• Windows 2003 

• Windows Server 2008/R2 
 
 

2.2 Downloading Kernel for VHD for the First Time 

After checking your computer with the prescribed system requirements for Kernel for VHD, you can  download 

and install the software on your computer. If you want to try using Kernel for VHD tool before buying it, you 

can download the evaluation version from the following link: http://www.nucleustechnologies.com/vhd-

recovery.html 
 

2.3 Install Kernel for VHD 

After downloading the installer file, execute the following steps for installing the software:  

1. Double- click Kernel for VHD installer file. 
2. Follow the on-screen instructions. When the installation process completes ‘Setup  Installation Complete’ 

message appears on the software installation screen. 
3. Click the Finish button to launch the software. 

 
After the completion of the software installation process, a shortcut to start the software will be added to the 

Windows Start Program menu. Users can start the software from the Program menu. One can also create a 

desktop icon of the software wherefrom it can be started by double-clicking the icon. 

 

http://www.nucleustechnologies.com/vhd-recovery.html
http://www.nucleustechnologies.com/vhd-recovery.html
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 Before proceeding to uninstall Kernel for VHD software, you must ensure that the 
software is not running. 

2.4 Start Kernel for VHD 

To start Kernel for VHD software, Click Start > All Programs > Kernel for VHD. 

Alternatively, you can launch Kernel for VHD by double-clicking the shortcut icon available on the desktop and 

Quick Launch icon. 

2.5 Uninstall Kernel for VHD 

User can uninstall Kernel for VHD software from a computer system by using one of the following two methods: 

• Uninstall from Windows Start menu 

• Uninstall from Control Panel 
 

 
 
 

2.5.1 Uninstall from Windows Start menu 

Execute the following steps to uninstall Kernel for VHD from Windows Start menu: 
 

1. Click Start > All Programs > Kernel for VHD > Uninstall Kernel for VHD. A warning message before 

uninstalling the software will be displayed on the screen. 

2. Click the Yes button to uninstall the software. 

3. Click the OK button. 

 

 

 

2.5.2 Uninstall from Control Panel 

Execute the following steps to uninstall Kernel for VHD from Control Panel: 

1. Click Start > Control Panel. The Control Panel window appears. 

2. Double-click the Add or Remove Programs icon. A list of the programs installed on the computer 

system appears. 

3. Select Kernel for VHD and click the Remove button. A warning message before uninstalling the 

software will be displayed on the screen. 

4. Click the Yes button to uninstall the software. 

5. Click the OK button. 
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3. Getting started with the User Interface 

3.1 Welcome Screen 

Now, you have got a clear idea about the features of Kernel for VHD. So, it’s time to get acquainted with the 

working of the tool. When you install and run Kernel for VHD, the following welcome screen appears. 

 

 
 

 

 

3.2 Menu-bar 

Figure 3.1: Welcome Screen 

The Menu bar of Kernel for VHD comprises the following four menus: 

• Recovery Menu 

• View Menu 

• Tools Menu 
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• Help Menu 

 

3.2.1 Recovery Menu 

Recovery menu of the Kernel for VHD software appears, as shown in the following figure: 
 

 

Figure 3.2: Recovery Menu 
 

 
The following table enlists the options available in the Recovery menu: 

 

Field Name Field Description 

Open Select this option to add a corrupt VHD/VHDX file to 
the application. 

Recover Selected Select this option to start the process of saving the 

recoverable 

Save Recovery Snapshot 
Select this option to save the recoverable data as a 
snapshot when you do not have time to sit and wait 
for the data to be saved on your computer’s hard 
disk or another storage media. 

Load Recovery Snapshot 
Select this option to load the saved snapshot. 

Exit 
Select this option to close the software. 

 
 
 

3.2.2 View Menu 

The View menu allows changing the pattern of viewing the recovered files in the software. View menu of 

Kernel for VHD software appears, as shown in the following figure: 

 

Figure 3.3: View Menu 
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Following table enlists the options available in the View Menu: 
 
 

Field Name Field Description 

Icons Select this option to view the recovered files in form of 

icons. 

List Select this option to view the recovered files in a list-like 

structure. 

Details Select this option to view the recovered files with 

complete details such as size. 

 
 

3.2.3 Tools Menu 

Tools menu of Kernel for VHD software appears, as shown in the following figure: 
 

Figure 3.4: Tools Menu 

Following table enlists the options available in the Tools menu: 

Field Name Field Description 

Find Files Select this option to find a specific file(s) from the recovered 

file(s). For example, if you need to view .xls files, then type 

*.xls in the “Find Files” dialog box and the software will 

display all the MS Excel file(s) amongst the recovered files. 

File Filters This option works similar to the Find Files option. However, 

the only difference is while using the Find Files option, you 

can search for a specific type of file, say *.xls; but with the 

File Filters option, you can specify multiple file types, say 

*.xls, *.docx, *.pdf, etc. Based on the file type(s) you specify, 

the software displays the recovered items. 

Settings Select this option to configure following software settings, 
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Button Recover Button Description 

 based on which the software will search the lost files and 
folders: 

• Sectors to be read in one attempt. 

• Rename, overwrite, or skip the duplicate files. 

• Include deleted files 

• Exclude deleted files 

• Recover only deleted files. 

Drive Information Select this option to gather information about the system 

drive. 

 
3.2.4 Help Menu 

 

The Help menu of the Kernel for VHD software appears, as shown in the following figure: 
 

 

Figure 3.5: Help Menu 
 
 

The following table enlists the options available in the Help menu: 
 

Field Name Field Description 

Help Select this option to view Help manual of the software. 

About Kernel for VHD Select this option to view version information and the 

support details of the software. 

 
 

3.3 Tool-bar 

The toolbar consists of buttons that work as shortcuts for various options available in the main menus 
of Kernel for VHD software. The following table enlists the buttons available on the Toolbar of the 
software: 
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Recover Click this button to start the saving process. 

 

 

Save Snapshot Click this button to save the recovery snapshot. 

 

 

Load Snapshot Click this button to load the recovery snapshot. 

 

 

Find Click this button to enter and search specific file types 

 

 

Setting Click this button to view and modify following software 

settings based on which the software will search the 

lost files and folders: 

• Sectors to be read in one attempt 

• Rename, overwrite, or skip the duplicate files 

• Include deleted files in the search, exclude 

deleted 

• files from recovered files, or only recover the 

• deleted files 

• Number of retries on bad sectors 

 
 

3.4 Buttons Used 

There are several buttons used in the software that helps user throughout the recovery process. The 
following table lists the buttons used in the software: 

 
 
 

Button 

 
 

Description 

 

Click this button to start the saving process. 
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Click this button to hide the searching process. While searching for the 
files and folders on the selected hard disk partition or logical disk drive, 
the software displays the progress. If you do not want to see that 
progress, then just click the “Hide Progress” button. Clicking the “Hide 
Progress” button also improves the recovery speed.  

 

Click this button to view the searching progress. 

 

Click this button to proceed to the next step during the recovery 
process. 

 

Click this button to navigate back during the recovery process.  

 

Click this button to stop the searching or saving process in-between. 

 
4. Using Kernel for VHD 
Kernel for VHD provides three extensive file recovery modes which recover corrupted, inaccessible or damaged 

VHD and VHDX files. The recovery modes are as follows: 

• Quick Scan 

• Extensive Scan 

• File Trace 

 

4.1 Recover Data Using Quick Scan Mode 

The Quick Scan mode is the fastest recovery mode and resolves minor corruption issues in VHD and VHDX files 

stored in the hard disk of the computer. Execute the following basic steps to recover data using Quick Scan 

mode. 

1. Click Start > All Programs > Kernel for VHD > Kernel for VHD to launch the software. The welcome 
screen of the software appears. 

2. Browse and select the VHD/VHDX file. 
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Figure 4.1: Selecting VHDX File for Quick Scan Recovery Mode 

3. Select Quick Scan mode. The Quick Scan interface appears. 

4. Select a Virtual Hard Disk from the left panel of the window. The detail of the virtual hard disk is 
shown in the right panel. 

5. Click Next to continue the recovery process. 
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Figure 4.2: Selecting Drive to Recover for Quick Scan Recovery Mode 
 
 

A dialog box is displayed. Select the radio button Use existing partition info to recover data from an existing 
partition on the selected hard disk. Else, select the Search partition option. 

 

6.  Click OK to continue. 
 
The partition searching process takes place. You can stop the process in between by using the Stop button. 
The available partitions are displayed in the left panel. 
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 You can show or hide the progress of the search process by clicking the Hide Progress/ 
Show Progress buttons. 

 
 

Figure 4.3: Selecting the Partition for Quick Scan Recovery Mode 

7. Select any partition displayed in the left panel of the window. You can view the details of the partition 

by clicking it. 

8. Click Next. The folder searching process is executed. 
 

When the search process completes, all the folders are enlisted in the left panel. You can expand the folders 

and view their details displayed in the right panel. 

9. Select and check the folders which you want to recover. 

10. Click the Recover button. 

The software displays a dialog box asking you to provide the location for saving the recovered files. 
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Figure 4.4: Selecting Folder to Recover for Quick Scan Recovery Mode 

11. Specify the location to save the selected items and click OK button. 

When the saving process is done, the software displays a dialog box containing message regarding successful 

saving of files. 
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Figure 4.5: Displaying successful saving of files for Quick Scan Recovery Mode 

12. Click the OK button to close the dialog box. 

You can view the recovered files from the specified locations. 
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4.2 Recover Data Using Extensive Scan Mode 

The Extensive Scan Mode is the powerful recovery mode that performs intensive scanning of the 
corrupted or damaged VHD and VHDX files. This mode can effectively recover the files that cannot be 
recovered by Quick Scan mode. 

Execute the following steps to recover data using Extensive Scan mode: 

1. Click Start > All Programs > Kernel for VHD > Kernel for VHD to launch the software. The 
welcome screen of the software appears. 

2. Browse and select the VHD/VHDX file. 

 

 

Figure 4.6: Selecting Recovery Mode for Extensive Scan Mode 

3. Select Extensive Scan mode. The Extensive Scan interface appears. 

4. Select a Virtual Hard Disk from the left panel of the window. The detail of the Virtual Hard Disk is 
shown in the right panel. 

5. Click Next to continue the recovery process. A dialog box is displayed. Select the radio button Use 
existing partition info to recover data from an existing partition on the selected hard disk. Else, select the 

Search partition option. 

6. Click OK to continue. 
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Figure 4.7: Selecting partitions type for Extensive Scan Mode 

 

The partition searching process takes place. Users can stop the process in between by using the Stop button. 
The available partitions are displayed in the left panel. 

7. Click Next. 

8. Select the File System from the left panel of the window. 

9. Click Next. 
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 Note: You can show or hide the progress of the search process by clicking the Hide 
Progress/ Show Progress buttons. You can also stop the search process by clicking the 
Stop button. 

 

Figure 4.8: Partition information for Extensive Scan Mode 

The folder searching process is executed. 

 
 

 

When the search process completes, the recovered file system is enlisted in the left panel. Select the file Click 
Next. 

All the folders within this file are listed in the left panel. You can expand the folders and view their details 
displayed in the right panel. 

10. Select and check the folders which you want to recover. 

11. Click the Recover button. 

The software displays a dialog box asking you to provide the location for saving the recovered files. 
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Figure 4.9: Selecting Folder to recover for Extensive Scan Mode 
 

12. Specify the location to save the selected items and click the OK button. When the saving is done, the software 
displays a dialog box containing a message regarding the successful saving of files. 

13. Click the OK button to close the dialog box. 
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Figure 4.10: Displaying successful saving of files in Extensive Scan Mode 

User can view the recovered files from the specified locations. 

 

4.3 Recover Data Using File Trace Mode 

The File Trace method is capable to recover those files that cannot be recovered with Quick Scan and 
Extensive Scan modes. With the help of raw scanning of the corrupted and damaged files, it recovers the data. 

Using following simple steps, recover the VHD and VHDX files using File Trace method: 
 

1. Click Start > All Programs > Kernel for VHD > Kernel for VHD to launch the software. The welcome screen 
of the software appears. 

2. Browse and select the VHD or VHDX file. 
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Figure 4.11: Selecting File for File Trace Method 
 

3. Select File Trace mode. The File Trace interface appears. 

4. Select a Virtual Hard Disk from the left panel of the window. The detail of the virtual hard disk is 
shown in the right panel. 

5. Click Next to continue the recovery process. 
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Figure 4.12: Selecting Drive to Recover for File Trace Method 
 

A dialog box is displayed. Select the radio button Use existing partition info to recover data from an existing 
partition on the selected hard disk. Else, select the Search partition option. 

6. Click OK to continue. 

The partition searching process takes place. You can stop the process in between by using the Stop button. 
The available partitions are displayed in the left panel. 

7. Click Next. 
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 Note: You can select single or multiple file types for recovery. 

 

Figure 4.13: Selecting Partition to Recover for File Trace Method 

8. Click OK to continue. The File Types interface appears. 
 

9. Check the files you want to recover from the File Types interface. 

10. Click OK to continue. The data searching process takes place. 



© KernelApps Private Limited 
 

 Note: You can show or hide the progress of the search process by clicking the Hide 
Progress/ Show Progress buttons. You can also stop the search process by clicking the 
Stop button. 

 

Figure 4.14: Selecting File Types to Recover for File Trace Method 
 

After successful completion of the search, the folders with all file types inside them are displayed in a tree-like 
structure in the left panel. You can expand the folders and view their details displayed in the right panel. 

11. Select the file types that you want to recover. 

12. Click the Recover button. 

The software displays a dialog box asking you to provide the location for saving the recovered files. 

13. Specify the location to save the selected items and click the OK button. 
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Figure 4.15: Selecting a path to save the recovered data in the File Trace Method 

When the saving process is done, the software displays a dialog box containing a message regarding the 

successful saving of files. 

14. Click the OK button to close the dialog box. 
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Figure 4.16: Displaying successful saving of recovered data in File Trace Method 

User can view the recovered files from the specified location. 

 

5. Troubleshooting 
This section deals with your generic and specific queries pertaining to using Kernel for VHD.  

5.1 Common Issues 

What are the limitations in the trial version of Kernel for VHD? 

The free demo version of Kernel for VHD works almost the same as that of the full version of the software but 
with a limitation that saves the recovered VHD/VHDX files up to 250 MB only. 

 

 

5.2 Frequently Asked Questions 

 
         1 . How to purchase Kernel for VHD? 

One can buy Kernel for VHD from our website: http://www.nucleustechnologies.com/buy-vhd- recovery.html 
 
2.  I have lost my full version for Kernel for VHD. Can you help me? 

Please email us at sales@nucleustechnologies.com Please include your name, address, email address, and 

order confirmation number (if you have it). We will be happy to help you. 

 

http://www.nucleustechnologies.com/buy-vhd-recovery.html
http://www.nucleustechnologies.com/buy-vhd-recovery.html
mailto:sales@nucleustechnologies.com
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3. What are the three recovery modes in Kernel for VHD? 

The three recovery modes for Kernel for VHD are Quick Scan, Extensive Scan, and File Trace.  

4. What are the supported Windows OS Platforms for Kernel for VHD? 

The supported Windows OS Platforms for Kernel for VHD are Windows 10, Windows 8.1, Windows 8, 

Windows 7, Windows Vista, Windows XP, Windows 2000, Windows 2003, and Windows Server 2008/R2 , etc. 

5. What are the various reasons for the corruption of VHD/VHDX files? 

VHD and VHDX files may get corrupted due to partition deletion, partition damage, and partition formatting. 

6. Give the link for downloading the free trial version of Kernel for VHD.  
The free trial version of Kernel for VHD can be downloaded using the link:        
http://www.nucleustechnologies.com/download-vhd-recovery.html 

 

 6. Conclusion 
The User Guide is easy to understand and helps to recover corrupt or inaccessible SQL Server 

databases to Batch File and Live SQL Server. Learn more about the product and its benefits here:  

https://www.nucleustechnologies.com/vhdrecovery.html 

 

7. Support 
Connect to our experts immediately while facing any issues during installation, configuration, or 

associated 

matters: 

• 1-866-348-7872 

• 0-808-189-1438 

Additionally, you can connect with us at https://www.nucleustechnologies.com/Contact.html  to 

submit your 

query, or chat with one of our support team. 

Moreover, you can write to us at the following email addresses: 

• sales@nucleustechnologies.com  (for Sales Queries) 

• support@nucleustechnologies.com  (for Support Queries) 

 

 

 

http://www.nucleustechnologies.com/download-vhd-recovery.html
https://www.nucleustechnologies.com/vhdrecovery.html
https://www.nucleustechnologies.com/Contact.html
mailto:sales@nucleustechnologies.com
mailto:support@nucleustechnologies.com
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8. Copyright 
           KernelApps Private Limited accompanied Installation & configuration manual, and documentation is 

copyright of KernelApps Private Limited, with all rights reserved. Under the copyright laws, this user 

manual cannot be reproduced in any form without the prior written permission of KernelApps Private 

Limited. No Patent Liability is assumed, with respect to the use of the information contained herein.  

         © KernelApps Private Limited. All rights reserved. 

 

-end- 


