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1. Introduction to Kernel SQL Database Recovery 

Welcome to the User Manual for Kernel SQL Database Recovery, an effective and powerful data 
recovery software to recover data from the corrupt SQL databases (.MDF). This user manual 
comprises step-by-step guidelines on using Kernel SQL Database  Recovery software. 

  
1.1 Using this Manual 

This User Manual is intended to guide users on using Kernel SQL Database Recovery. We suggest 
that first time users should read this User Manual completely and carefully before proceeding to 
use the software. However, if you are an experienced user, you can use the Table of Contents to 
find out information pertaining to the tasks that you need to perform by using Kernel SQL Database 
Recovery. 

 

You can use the Table of Contents to navigate through different sections of this User Manual. The 
Table of Contents enlists all the sections contained within this user manual in chronological order.  

 

1.1.1 List of Abbreviations 
 

Certain abbreviations have been used throughout this manual. For a clear understanding of the contents of 
this user manual, please go through the list of abbreviations, mentioned below, before reading the manual. 

 

o MS: Microsoft 
 

o SQL: Structured Query Language 
 

o QFSCI: Quick File System Component Identification 
 

o RAM: Random Access Memory 

o MB: Mega-Byte 

o GB: Giga-Byte 

 
1.1.2 About Kernel SQL Database Recovery 

Kernel SQL Database Recovery is an advanced and professional database recovery software 
that recovers data from corrupt, damaged .MDF database files. Kernel SQL Database Recovery 
software is equipped with powerful QFSCI algorithm which efficiently scans and retrieves data 
from the corrupt databases. 
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The common reasons which lead to SQL database corruptions are:  

• Invalid database file header 

• Not able to associate database file with different databases 

• Internal Program Error(s) Crash or Failure of hard drive 

• Media contamination or damage  

• Accidental deletion of data and files  

• Accidental reformatting of partitions  

• Virus attacks 

• Data corruptions 

 

1.2 Salient Features 

 

 Salient features of Kernel SQL Database Recovery include: 

 

• Effectively repairs and extracts data from the corrupt SQL database (.MDF).  

• Creates script file(s) where the recovered files are saved. 

• Deleted records can be recovered and are saved in a separate SQL script.  

• Accurately recovers Microsoft SQL Server backup files. 

• Accurately recovers all database objects contained within MDF files including tables, 
triggers, views, stored procedures, primary keys, indexes, unique keys, foreign keys, 
predefined defaults, default values, rules, checks, and user data types (default, rule, Allow 
null) 

• Capable of restoring data on the server while SQL Server is still running  

• Preserves Structure and properties of recovered SQL databases objects  

• Recovers multiple MDF Files and folders in no matter of time 

• Efficiently repairs large-sized MDF files 

• Fully supports the recovery of data from MDF files created with SQL Server version 2000, 
2005, 2008, 2008 R2, 2012, 2014, 2016, 2017, & 2019 

• Offers an easy-to-use, self-descriptive, user-friendly Graphical User Interface. No technical 
skills required for operating the software 

• Available as a free to download the demo version 

• Offers round-the-clock technical support 
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1.3 Who Should Use This Software? 

The capability of Kernel SQL Database Recovery to repair large-sized SQL databases makes it 
appropriate for use by SQL Server administrators, who need to recover data from corrupt or 
damaged MDF database files. The corruption could have been caused due to virus attacks, 
improper system shutdown, network problems, database file header corruption, etc. 

 

2. Getting Started 

Now that you have understood the features and potential of Kernel SQL Database Recovery, you 
are ready to get a hands-on experience of the software. To start repairing MDF files, you will first 
need to download and install this software. 

 

It is strongly recommended that before installing Kernel SQL Database Recovery, you should go 
through the installation pre-requisites for the software to ensure that your computer is 
appropriately configured to run the software. 

 

2.1 Installation Pre-requisites 

The various pre-requisites for installing and running Kernel SQL Database Recovery can be 
broadly classified into two major categories – Hardware requirements and Software 
requirements. 

 

2.1.1 Hardware Requirements 
 

The hardware requirements for installing the software are as follows: 

Pentium Class Processor 

Minimum 64MB RAM (128 MB Recommended) 10MB free space for 

Software Installation 

Disk Space - Enough disk space to save the results 
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2.1.2 Software Requirements 

The software requirements for installing the software can further be grouped into two 
categories – Operating System requirements and SQL Server version requirements. The 
requirements are as follows: 

 
2.1.2.1 Operating System Requirements 

 

Supported Windows Platforms:  

• Windows 10 
• Windows 8/8.1 
• Windows 7 

• Windows Vista 
• Windows XP 

 
• Windows Server 2000 

• Windows Server 2003 
• Windows Server 2008 
• Windows Server 2008 R2 
• Windows Server 2012 

• Windows Server 2016 
• Windows Server 2019 

 

2.1.2.2 SQL Server Version Requirements 

Supported MS SQL Server Versions: 

 
• SQL Server 2000 

• SQL Server 2005 
• SQL Server 2008 
• SQL Server 2008 R2 
• SQL Server 2012 

• SQL Server 2014 
• SQL Server 2016 
• SQL Server 2017 
• SQL Server 2019 

 

2.2 Downloading Kernel SQL Database Recovery for the First Time 

After checking your computer with the prescribed system requirements for Kernel SQL Database 
Recovery, you can download and install the software on your computer.  
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If you want to try using Kernel SQL Database Recovery before buying it, you can download the 
evaluation version from the following link: 

 

https://www.nucleustechnologies.com/download-sql-recovery.php 
 
 

 

 
 

2.3 Install Kernel SQL Database Recovery 

After downloading the installer file for Kernel SQL Database Recovery, you can install the 
software by running the file. To install Kernel SQL Database Recovery: 

 

1. Double-click the Kernel SQL Database Recovery installer. 
 

2. Follow the on-screen instructions. 
 

3. The Setup Installation Complete screen gets displayed. 
 

4. Click Finish to launch the software. 

 

2.4 Start Kernel SQL Database Recovery 

To start Kernel SQL Database Recovery: 
 

1. Click Start →  All Programs →  Kernel SQL Database Recovery 
 

 
Alternatively, you can launch Kernel SQL Database Recovery by double-clicking the 

shortcut icon available on the desktop and Quick Launch icon. 

 

2.5 Uninstall Kernel SQL Database Recovery 

You may need to uninstall and re-install Kernel SQL Database Recovery. To uninstall Kernel SQL 
Database Recovery: 

 

1. Click     Start → All   Programs → Kernel  SQL  Database Recovery → Uninstall  
Kernel SQL   

 
A warning message will be displayed. 

 

2. Click ‘Yes’ to uninstall Kernel SQL Database Recovery. 

 You can repair .MDF files saved on your system by using the evaluation version of Kernel SQL Database Recovery; 
however, the repaired file will not be saved until you purchase the full version of the software.  

http://www.nucleustechnologies.com/download-sql-recovery.php
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You can alternatively uninstall Kernel SQL Database Recovery from the Control Panel by 
performing the following steps: 

 

1. Click the S tart Menu → Control Panel and then double-click the Add or Remove Programs icon. 
 

2. Select Kernel SQL Database Recovery and click Remove.  
     A warning message will be displayed. 

 

3. Click ‘Yes’ to uninstall Kernel SQL Database Recovery. 

 Before proceeding to uninstall Kernel SQL Database Recovery, you must ensure that the 
software is not running. 
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3. Software Interface 

Now that Kernel SQL Database Recovery has been installed on your computer, you can start using the software 
after getting acquainted with the software interface. 

 

3.1 Menu Bar 

The Menu bar of Kernel SQL Database Recovery comprises three menus: 

 
File Menu 

Tools Menu 

Help Menu 

3.1.1 File Menu 
 

The File menu comprises three menu items: 
 

Figure 3.1: File Menu 

 

The following table enlists the options available in the File menu: 
 

Option Description 

Open Select this option to locate the damaged SQL database on your hard disk  

Save Select this option to save the data so recovered from the SQL database 

Exit Select this option to close the application 

 

 

3.1.2 Tools Menu 

The Tools menu comprises only one menu item: 
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Figure 3.2: Tools Menu 

 
 
On clicking on Options menu item, the software offers two options that are: 

 

Option Description 

Consider all pages as corrupted Highly-recommended to select this option; proves useful in 
recovering data from heavily-corrupted databases 

Save the tables without identity 
property 

Select this option if tables are not saving due to corrupted data. 
Checking this option will allow saving the tables without identity; you 
can set the identity of these tables after recovery 

 

 

3.1.3 Help Menu 

The Help menu of Kernel SQL Database Recovery software appears, as shown in the following figure: 
 

Figure 3.3: Help Menu 

 

The following table enlists the options available in the Help menu: 
 

Option Description 

Kernel SQL Database Recovery Help Select this option to view Help manual of the software 

Kernel SQL Database Recovery 
Homepage 

Select this option to visit the webpage to know more about the 
software 

About Kernel SQL Database 
Recovery 

Select this option to view version information about the 
software and various other related links 
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3.2 Tool Bar 

Toolbar consists of buttons that work as short cuts for various options available in the main menus of Kernel SQL 
Database Recovery software. The following table enlists the buttons available on the Toolbar of the software: 

 
 

Button Description 

 

Select this option to locate the damaged SQL database on your hard disk  

 

 

Select this option to save the data so recovered from the SQL database 

 

Select this option to view Help manual of the software 

 

 
 

3.3 Buttons Used 

There are several buttons used in the software that helps you throughout the recovery process. The following table 
enlists the buttons used in the software: 

 

Button Description 

 
This option initiates the recovery process of the selected database 

 
This option cancels the action and closes the dialog 

 
This option lets you locate the damaged SQL database 

 This option takes you to the previous page in the record 

 This option takes you to the next page in the record 

 
This option lets you stop the ongoing process 

 This option allows you to refresh the process 
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4. Repairing MDF Files 

Kernel SQL Database Recovery is an ideal software that helps you restore objects from corrupt databases. No matter 
what made your MDF database corrupt or inaccessible, the Kernel SQL database Recovery will recover your data easily 
and quickly. Follow the steps given below to repair SQL Databases: 

 

1. Select Start > All Programs > Kernel SQL Database Recovery > Kernel SQL Database Recovery 
to launch the software. The software home window appears: 
 

                      
Figure 4.1: Home Window of Kernel SQL Database Recovery 

 

 

 
2. Click the Browse button to locate the corrupt SQL Database: 

 
 
 
 
 
 

 "Select SQL Database" dialog appears by-default when the software is launched. This dialog can be 
launched by clicking the Open button in Tool bar or by selecting File menu > Open. 
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Figure 4.2: Locate Corrupt SQL Database 

 

3. Select the SQL Database version with which the .MDF file is created: 
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Figure 4.3: Select SQL Database Version 

 

4. Click the Recover button to initiate the recovery process, and Software will enlist the SQL database 
objects in the left pane: 
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Figure 4.4: Enlisted SQL Database Objects 

 
 
 

Note that, if the user selects the wrong SQL Server version, the software displays the following error 
message: 

 

Figure 4.5: Error Message on the selection of wrong SQL 

Server version 
 

5. Select an object in the left tree whose content you want to verify before saving. When you select  
the folder, its content will be displayed in the right pane: 
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Figure 4.6: Preview of Selected Object 

 

6. After previewing the required items, select the data for saving, and then click the Save button. 
The 'Saving Mode' dialog box appears: 
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Figure 4.7: Available Saving Modes 
 

You can save the recovered objects in two different modes which      are: 
 

a. SQL Server: Using this option, the recovered objects can be saved on SQL Server directly, even if the 
server is running. To save the data on SQL Server: 

 

1. Mention Server Name and Name of the database in Server Name and Database Name fields respectively. 
Do not provide the name of an existing database in the Database Name field. Create a new database in 
SQL Server Management Studio and enter the name of the new database in the Database Name field. 
However, existing database name can also be provided but in case of existing database restored objects 
will get merged with existing objects. 

2. Select the Authentication option with which you wish to access the SQL Server, i.e. Windows 
Authentication or Server Authentication. To access SQL Server with Server Authentication, you need to 
enter User Name and Password in the respective fields. 

 
 
 
 
 
 
 
 
 
 

© KernelApps Private Limited  

 To save the data, you can click the Save button on the Tool bar or go to File menu > Save 
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b. Batch File: Using this option, you can save the batch file of the rebuilt SQL database on the desired location. 
To save the recovered, you need to browse the location using the Browse button. The data so recovered is 
saved in separate script files at the desired location. Also, a script file (commit.bat) is also created that 
enables the user to easily copy the recovered objects to a new database created on SQL Server. To copy 
recovered objects to a new database on SQL server: 

 

1. Go to SQL Server Management Studio 
 

2. Create a New Database 
 

3. Double-click on commit.bat 

OR 

(Run → cmd ) Change the path to the recovered folder ( cd PathName) 
 

4. Use the following syntax: 
 

                                     >commit.bat servername newcreateddatabase sqlserverusername sqlserverpassword 
 

Press Enter key and all tables will be copied to the new created database.  

 

7. After selecting the required Saving Mode option, click the OK button. The software starts saving the 
recovered objects: 
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Figure 4.8: Saving Database Objects in Progress 

 
 
 

8. The software displays the following 'Process Completed' dialog box when the data is saved successfully at 
the desired location: 
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Figure 4.9: Successful Saving of Database Objects 

 
9. Click OK button to close the 'Process Completed' dialog box. 

 

5. Troubleshooting 

5.1 Common Issues 
 

                  What is the limitation in the trial version of Kernel SQL Database Recovery? 
 

The trial version of Kernel SQL Database Recovery works almost the same as that of the full version of the software 
such that it accurately recovers entire database objects embedded within the SQL Server database MDF files, 
displays a preview of all the recovered objects but restricts users from saving them. In order to save the entire 
recovered SQL database objects, the user must purchase the full licensed version of the software. 

 

5.2 Frequently Asked Questions 
1. How to purchase Kernel SQL Database Recovery? 

One can buy Kernel SQL Database Recovery using the website: www.nucleustechnologies.com/buy-sql- 
recovery.php 

 

 
 

 

http://www.nucleustechnologies.com/buy-sql-recovery.php
http://www.nucleustechnologies.com/buy-sql-recovery.php
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2. What are the supported Windows OS platforms for Kernel SQL Database Recovery software? 

The supported Windows OS platforms for Kernel SQL Database Recovery software are Windows 8, Windows 7, 
Windows Vista,     Windows XP, Windows Server 2000, Windows Server 2003, Windows Server 2008, Windows 
Server 2008 R2,  Windows Server 2012, Windows Server 2016 and Windows Server 2019.  
 
 

3. What are the supported MS SQL Server versions for Kernel SQL Database Recovery software? 
The supported MS SQL Server versions for Kernel SQL Database Recovery software are: SQL Server 2000, SQL 
Server 2005, SQL Server 2008, SQL Server 2008 R2, SQL Server 2012, SQL Server 2016, SQL Server 2017 and 
SQL Server 2019. 

 

4. Give the link for downloading the free trial version of Kernel SQL Database Recovery  software. 
The free trial version of Kernel SQL Database Recovery software can be downloaded using the link: 
www.nucleustechnologies.com/download-sql-recovery.php 

6. Conclusion 

     The User Guide is easy to understand and helps to recover corrupt and inaccessible MDF files and save it to a 
batch file or live SQL Server. Learn more about the product and its benefits here:  
https://www.nucleustechnologies.com/sql-recovery.html 
 
 

7. Support 

Connect to our experts immediately while facing any issues during installation, configuration, or associated 
matters: 
• 1-866-348-7872 
• 0-808-189-1438 
Additionally, you can connect with us at https://www.nucleustechnologies.com/Contact.html 
to submit your query, or chat with one of our support team. 
Moreover, you can write to us at the following email addresses: 
• sales@nucleustechnologies.com  (for Sales Queries) 
• support@nucleustechnologies.com  (for Support Queries) 
 

8. Copyright 

KernelApps Private Limited accompanied Installation & configuration manual, and documentation is copyright of 
KernelApps Private Limited, with all rights reserved. Under the copyright laws, this user manual cannot be 
reproduced in any form without the prior written permission of KernelApps Private Limited. No Patent Liability is 
assumed, with respect to the use of the information contained herein.  
© KernelApps Private Limited. All rights reserved. 

-end- 
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